dart pub deps

Deps is one of the commands of the pub tool.

$ dart pub deps [--style=<style>] [--dev] [--no-dev] [--executables]

This command prints the dependency graph for a package. The graph includes both the immediate dependencies that the package uses (as specified in the pubspec), as well as the transitive dependencies pulled in by the immediate dependencies.

The dependency information is printed as a tree by default.

For example, the pubspec for the markdown_converter example specifies the following dependencies:

dependencies:
  barback: ^0.15.2
  markdown: ^0.7.2

Here’s an example of the dart pub deps output for markdown_converter:

$ dart pub deps
markdown_converter 0.0.0
|-- barback 0.15.2+6
|   |-- collection 1.1.2
|   |-- path 1.3.6
|   |-- pool 1.1.0
|   |   '-- stack_trace...
|   |-- source_span 1.2.0
|   |   '-- path...
|   '-- stack_trace 1.4.2
|       '-- path...
'-- markdown 0.7.2

Options

For options that apply to all pub commands, see Global options.

--style=<style> or -s <style>
The specified style determines the output format:
  • tree
    Prints dependency information as a tree. This is the default format.
  • list
    Prints dependency information as a list.
  • compact
    Prints dependency information as a compact list.
--dev
Prints all package dependencies, including dev dependencies. Dev dependencies are included by default.
--no-dev
Prints all package dependencies, excluding dev dependencies.
--executables
Prints all available executables.